USN-4102-1: LibreOffice vulnerabilities

19 August 2019

libreoffice vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in LibreOffice.

Software Description

  • libreoffice - Office productivity suite

Details

It was discovered that LibreOffice incorrectly handled LibreLogo scripts. If a user were tricked into opening a specially crafted document, a remote attacker could cause LibreOffice to execute arbitrary code. (CVE-2019-9850, CVE-2019-9851)

It was discovered that LibreOffice incorrectly handled embedded scripts in document files. If a user were tricked into opening a specially crafted document, a remote attacker could possibly execute arbitrary code. (CVE-2019-9852)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
libreoffice-core - 1:6.2.6-0ubuntu0.19.04.1
Ubuntu 18.04 LTS
libreoffice-core - 1:6.0.7-0ubuntu0.18.04.9
Ubuntu 16.04 LTS
libreoffice-core - 1:5.1.6~rc2-0ubuntu1~xenial9

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart LibreOffice to make all the necessary changes.

References