USN-415-1: GTK vulnerability

1 February 2007

gtk+2.0 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

A flaw was discovered in the error handling of GTK’s image loading library. Applications opening certain corrupted images could be made to crash, causing a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libgtk2.0-0 - 2.10.6-0ubuntu3.1
Ubuntu 6.06 LTS
libgtk2.0-0 - 2.8.20-0ubuntu1.1
Ubuntu 5.10
libgtk2.0-0 - 2.8.6-0ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session to effect the necessary changes.

References