USN-4153-1: Octavia vulnerability

10 October 2019

octavia vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04

Summary

Octavia could allow unintended access to network services.

Software Description

  • octavia - OpenStack Load Balancer Service

Details

Daniel Preussker discovered that Octavia incorrectly handled client certificate checking. A remote attacker on the management network could possibly use this issue to perform configuration changes and obtain sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
amphora-agent - 4.0.0-0ubuntu1.2
octavia-common - 4.0.0-0ubuntu1.2
python3-octavia - 4.0.0-0ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References