USN-4155-1: Aspell vulnerability

15 October 2019

aspell vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

Aspell could be made to expose sensitive information if it received a specially crafted input.

Software Description

  • aspell - GNU Aspell spell-checker

Details

It was discovered that Aspell incorrectly handled certain inputs. An attacker could potentially access sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
aspell - 0.60.7~20110707-6ubuntu0.1
libaspell15 - 0.60.7~20110707-6ubuntu0.1
Ubuntu 18.04 LTS
aspell - 0.60.7~20110707-4ubuntu0.1
libaspell15 - 0.60.7~20110707-4ubuntu0.1
Ubuntu 16.04 LTS
aspell - 0.60.7~20110707-3ubuntu0.1
libaspell15 - 0.60.7~20110707-3ubuntu0.1
Ubuntu 14.04 ESM
aspell - 0.60.7~20110707-1ubuntu1+esm1
libaspell15 - 0.60.7~20110707-1ubuntu1+esm1
Ubuntu 12.04 ESM
aspell - 0.60.7~20110707-1ubuntu0.1
libaspell15 - 0.60.7~20110707-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References