USN-4189-1: DPDK vulnerability

13 November 2019

dpdk vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 19.04
  • Ubuntu 18.04 LTS

Summary

DPDK could be made to consume resources if it received specially crafted input.

Software Description

  • dpdk - set of libraries for fast packet processing

Details

Jason Wang discovered that DPDK incorrectly handled certain messages. An attacker in a malicious container could possibly use this issue to cause DPDK to leak resources, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
dpdk - 18.11.4-1ubuntu0.19.10.1
Ubuntu 19.04
dpdk - 18.11.4-1ubuntu0.19.04.1
Ubuntu 18.04 LTS
dpdk - 17.11.8-0~ubuntu18.04.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

This update uses a new upstream release, which includes additional bug fixes. In general, a standard system update will make all the necessary changes.

References