USN-421-1: MoinMoin vulnerability

10 February 2007

moin, moin1.3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

A flaw was discovered in MoinMoin’s page name sanitizer which could lead to a cross-site scripting attack. By tricking a user into viewing a crafted MoinMoin page, an attacker could execute arbitrary JavaScript as the current MoinMoin user, possibly exposing the user’s authentication information for the domain where MoinMoin was hosted.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
python2.4-moinmoin - 1.5.3-1ubuntu1.1
Ubuntu 6.06 LTS
python2.4-moinmoin - 1.5.2-1ubuntu2.1
Ubuntu 5.10
moin - 1.2.4-1ubuntu2.1
python2.3-moinmoin - 1.3.4-6ubuntu1.1
python2.4-moinmoin - 1.3.4-6ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References