USN-4219-1: libssh vulnerability

10 December 2019

libssh vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

libssh could be made to run programs under certain conditions.

Software Description

  • libssh - A tiny C SSH library

Details

It was discovered that libssh incorrectly handled certain scp commands. If a user or automated system were tricked into using a specially-crafted scp command, a remote attacker could execute arbitrary commands on the server.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
libssh-4 - 0.9.0-1ubuntu1.3
Ubuntu 19.04
libssh-4 - 0.8.6-3ubuntu0.3
Ubuntu 18.04 LTS
libssh-4 - 0.8.0~20170825.94fa1e38-1ubuntu0.5
Ubuntu 16.04 LTS
libssh-4 - 0.6.3-4.3ubuntu0.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References