USN-422-1: ImageMagick vulnerabilities

15 February 2007

imagemagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

Vladimir Nadvornik discovered that the fix for CVE-2006-5456, released in USN-372-1, did not correctly solve the original flaw in PALM image handling. By tricking a user into processing a specially crafted image with an application that uses imagemagick, an attacker could execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libmagick9 - 7:6.2.4.5.dfsg1-0.10ubuntu0.2
Ubuntu 6.06 LTS
libmagick9 - 6:6.2.4.5-0.6ubuntu0.5
Ubuntu 5.10
libmagick6 - 6:6.2.3.4-1ubuntu1.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References