USN-4229-1: NTP vulnerability

9 January 2020

ntp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

A security issue was fixed in ntpq and ntpdc.

Software Description

  • ntp - Network Time Protocol daemon and utility programs

Details

It was discovered that ntpq and ntpdc incorrectly handled some arguments. An attacker could possibly use this issue to cause ntpq or ntpdc to crash, execute arbitrary code, or escalate to higher privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
ntp - 1:4.2.8p4+dfsg-3ubuntu5.10
Ubuntu 14.04 ESM
ntp - 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13+esm1
Ubuntu 12.04 ESM
ntp - 1:4.2.6.p3+dfsg-1ubuntu3.13

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References