USN-429-1: tcpdump vulnerability

6 March 2007

tcpdump vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

Moritz Jodeit discovered that tcpdump had an overflow in the 802.11 packet parser. Remote attackers could send specially crafted packets, crashing tcpdump, possibly leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
tcpdump - 3.9.4-4ubuntu0.1
Ubuntu 6.06 LTS
tcpdump - 3.9.4-2ubuntu0.1
Ubuntu 5.10
tcpdump - 3.9.1-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References