USN-434-1: Ekiga vulnerability

9 March 2007

ekiga, gnomemeeting vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

It was discovered that Ekiga had format string vulnerabilities beyond those fixed in USN-426-1. If a user was running Ekiga and listening for incoming calls, a remote attacker could send a crafted call request, and execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
ekiga - 2.0.3-0ubuntu3.2
Ubuntu 6.06 LTS
ekiga - 2.0.1-0ubuntu6.2
Ubuntu 5.10
gnomemeeting - 1.2.2-1ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Ekiga or reboot your computer to effect the necessary changes.

References