USN-453-1: X.org vulnerability

18 April 2007

libx11 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

Details

Multiple integer overflows were found in the XGetPixel function of libx11. If a user were tricked into opening a specially crafted XWD image, remote attackers could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libx11-6 - 2:1.0.3-0ubuntu4.1
Ubuntu 6.06 LTS
libx11-6 - 2:1.0.0-0ubuntu9.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session or reboot your computer to effect the necessary changes.

References