USN-481-1: ImageMagick vulnerabilities

10 July 2007

imagemagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

Details

Multiple vulnerabilities were found in ImageMagick’s handling of DCM and WXD image files. By tricking a user into processing a specially crafted image with an application that uses imagemagick, an attacker could execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libmagick9 - 7:6.2.4.5.dfsg1-0.14ubuntu0.1
Ubuntu 6.10
libmagick9 - 7:6.2.4.5.dfsg1-0.10ubuntu0.3
Ubuntu 6.06 LTS
libmagick9 - 6:6.2.4.5-0.6ubuntu0.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References