USN-498-1: libvorbis vulnerabilities

16 August 2007

libvorbis vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

Details

David Thiel discovered that libvorbis did not correctly verify the size of certain headers, and did not correctly clean up a broken stream. If a user were tricked into processing a specially crafted Vorbis stream, a remote attacker could execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libvorbis0a - 1.1.2.dfsg-1.2ubuntu2
Ubuntu 6.10
libvorbis0a - 1.1.2-1ubuntu1.2
Ubuntu 6.06 LTS
libvorbis0a - 1.1.2-0ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References