USN-504-1: Emacs vulnerability

28 August 2007

emacs21 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • emacs21

Details

Hendrik Tews discovered that emacs21 did not correctly handle certain GIF images. By tricking a user into opening a specially crafted GIF, a remote attacker could cause emacs21 to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
emacs21 - 21.4a+1-2ubuntu1.1
emacs21-nox - 21.4a+1-2ubuntu1.1
Ubuntu 6.10
emacs21 - 21.4a-6ubuntu2.1
emacs21-nox - 21.4a-6ubuntu2.1
Ubuntu 6.06 LTS
emacs21 - 21.4a-3ubuntu2.1
emacs21-nox - 21.4a-3ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart emacs to effect the necessary changes.

References