USN-511-1: Kerberos vulnerability

4 September 2007

krb5, librpcsecgss vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • krb5
  • librpcsecgss

Details

It was discovered that the libraries handling RPCSEC_GSS did not correctly validate the size of certain packet structures. An unauthenticated remote user could send a specially crafted request and execute arbitrary code with root privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libkadm55 - 1.4.4-5ubuntu3.2
librpcsecgss3 - 0.14-2ubuntu1.1
Ubuntu 6.10
libkadm55 - 1.4.3-9ubuntu1.4
librpcsecgss2 - 0.13-2ubuntu0.1
Ubuntu 6.06 LTS
libkadm55 - 1.4.3-5ubuntu0.5
librpcsecgss1 - 0.7-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References