USN-515-1: t1lib vulnerability

19 September 2007

t1lib vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • t1lib

Details

It was discovered that t1lib does not properly perform bounds checking which can result in a buffer overflow vulnerability. An attacker could send specially crafted input to applications linked against t1lib which could result in a DoS or arbitrary code execution.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libt1-5 - 5.1.0-2ubuntu0.7.04.1
Ubuntu 6.10
libt1-5 - 5.1.0-2ubuntu0.6.10.1
Ubuntu 6.06 LTS
libt1-5 - 5.1.0-2ubuntu0.6.06.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References