USN-516-1: xfsdump vulnerability

20 September 2007

xfsdump vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • xfsdump

Details

Paul Martin discovered that xfs_fsr creates a temporary directory with insecure permissions. This allows a local attacker to exploit a race condition in xfs_fsr to read or overwrite arbitrary files on xfs filesystems.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
xfsdump - 2.2.38-1ubuntu0.7.04.1
Ubuntu 6.10
xfsdump - 2.2.38-1ubuntu0.6.10.1
Ubuntu 6.06 LTS
xfsdump - 2.2.30-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References