USN-519-1: elinks vulnerability

25 September 2007

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • elinks

Details

Kalle Olavi Niemitalo discovered that if elinks makes a POST request to an HTTPS URL through a proxy, information may be sent in clear-text between elinks and the proxy. Attackers with access to the network could steal sensitive information (such as passwords).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
elinks - 0.11.1-1.2ubuntu2.2
Ubuntu 6.10
elinks - 0.11.1-1ubuntu2.2
Ubuntu 6.06 LTS
elinks - 0.10.6-1ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References