USN-523-1: ImageMagick vulnerabilities

3 October 2007

imagemagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • imagemagick

Details

Multiple vulnerabilities were found in the image decoders of ImageMagick. If a user or automated system were tricked into processing a malicious DCM, DIB, XBM, XCF, or XWD image, a remote attacker could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libmagick9 - 7:6.2.4.5.dfsg1-0.14ubuntu0.2
Ubuntu 6.10
libmagick9 - 7:6.2.4.5.dfsg1-0.10ubuntu0.4
Ubuntu 6.06 LTS
libmagick9 - 6:6.2.4.5-0.6ubuntu0.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References