USN-534-1: OpenSSL vulnerability

22 October 2007

openssl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • openssl

Details

Andy Polyakov discovered that the DTLS implementation in OpenSSL was vulnerable. A remote attacker could send a specially crafted connection request to services using DTLS and execute arbitrary code with the service’s privileges. There are no known Ubuntu applications that are currently using DTLS.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libssl0.9.8 - 0.9.8e-5ubuntu3.1
Ubuntu 7.04
libssl0.9.8 - 0.9.8c-4ubuntu0.2
Ubuntu 6.10
libssl0.9.8 - 0.9.8b-2ubuntu2.2
Ubuntu 6.06 LTS
libssl0.9.8 - 0.9.8a-7ubuntu0.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to reboot your computer to effect the necessary changes.

References