USN-537-2: Compiz vulnerability

2 November 2007

compiz vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10

Software Description

  • compiz

Details

USN-537-1 fixed vulnerabilities in gnome-screensaver. The fixes were incomplete, and only reduced the scope of the vulnerability, without fully solving it. This update fixes related problems in compiz.

Original advisory details:

Jens Askengren discovered that gnome-screensaver became confused when running under Compiz, and could lose keyboard lock focus. A local attacker could exploit this to bypass the user’s locked screen saver.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
compiz-core - 1:0.6.0+git20071008-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session to effect the necessary changes.

References