USN-540-1: flac vulnerability

13 November 2007

flac vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • flac

Details

Sean de Regge discovered that flac did not properly perform bounds checking in many situations. An attacker could send a specially crafted FLAC audio file and execute arbitrary code as the user or cause a denial of service in flac or applications that link against flac.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libflac8 - 1.1.4-3ubuntu1.1
Ubuntu 7.04
libflac7 - 1.1.2-5ubuntu2.1
Ubuntu 6.10
libflac7 - 1.1.2-5ubuntu1.1
Ubuntu 6.06 LTS
libflac7 - 1.1.2-3ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References