USN-542-1: poppler vulnerabilities

14 November 2007

poppler vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • poppler

Details

Secunia Research discovered several vulnerabilities in poppler. If a user were tricked into loading a specially crafted PDF file, a remote attacker could cause a denial of service or possibly execute arbitrary code with the user’s privileges in applications linked against poppler.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libpoppler2 - 0.6-0ubuntu2.1
Ubuntu 7.04
libpoppler1 - 0.5.4-0ubuntu8.2
Ubuntu 6.10
libpoppler1 - 0.5.4-0ubuntu4.3
Ubuntu 6.06 LTS
libpoppler1 - 0.5.1-0ubuntu7.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session to effect the necessary changes.

References