USN-545-1: link-grammar vulnerability

26 November 2007

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10

Software Description

  • link-grammar

Details

Alin Rad Pop discovered that AbiWord’s Link Grammar parser did not correctly handle overly-long words. If a user were tricked into opening a specially crafted document, AbiWord, or other applications using Link Grammar, could be made to crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
liblink-grammar4 - 4.2.2-4ubuntu0.7.10.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart AbiWord to effect the necessary changes.

References