USN-551-1: OpenLDAP vulnerabilities

4 December 2007

openldap vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • openldap2.3
  • openldap2.2

Details

Thomas Sesselmann discovered that the OpenLDAP slapd server did not properly handle certain modify requests. A remote attacker could send malicious modify requests to the server and cause a denial of service. (CVE-2007-5707)

Toby Blake discovered that slapd did not properly terminate an array while running as a proxy-caching server. A remote attacker may be able to send crafted search requests to the server and cause a denial of service. This issue only affects Ubuntu 7.04 and 7.10. (CVE-2007-5708)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
slapd - 2.3.35-1ubuntu0.1
Ubuntu 7.04
slapd - 2.3.30-2ubuntu0.1
Ubuntu 6.10
slapd - 2.2.26-5ubuntu3.2
Ubuntu 6.06 LTS
slapd - 2.2.26-5ubuntu2.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References