USN-553-1: Mono vulnerability

4 December 2007

mono vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • mono

Details

It was discovered that Mono did not correctly bounds check certain BigInteger actions. Remote attackers could exploit this to crash a Mono application or possibly execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libmono-corlib1.0-cil - 1.2.4-6ubuntu6.1
libmono-corlib2.0-cil - 1.2.4-6ubuntu6.1
libmono-security1.0-cil - 1.2.4-6ubuntu6.1
libmono-security2.0-cil - 1.2.4-6ubuntu6.1
Ubuntu 7.04
libmono-corlib1.0-cil - 1.2.3.1-1ubuntu1.1
libmono-corlib2.0-cil - 1.2.3.1-1ubuntu1.1
libmono-security1.0-cil - 1.2.3.1-1ubuntu1.1
libmono-security2.0-cil - 1.2.3.1-1ubuntu1.1
Ubuntu 6.10
libmono-corlib1.0-cil - 1.1.17.1-1ubuntu7.2
libmono-corlib2.0-cil - 1.1.17.1-1ubuntu7.2
libmono-security1.0-cil - 1.1.17.1-1ubuntu7.2
libmono-security2.0-cil - 1.1.17.1-1ubuntu7.2
Ubuntu 6.06 LTS
mono-classlib-1.0 - 1.1.13.6-0ubuntu3.3
mono-classlib-2.0 - 1.1.13.6-0ubuntu3.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References