USN-556-1: Samba vulnerability

18 December 2007

samba vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • samba

Details

Alin Rad Pop discovered that Samba did not correctly check the size of reply packets to mailslot requests. If a server was configured with domain logon enabled, an unauthenticated remote attacker could send a specially crafted domain logon packet and execute arbitrary code or crash the Samba service. By default, domain logon is disabled in Ubuntu.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libsmbclient - 3.0.26a-1ubuntu2.3
samba - 3.0.26a-1ubuntu2.3
Ubuntu 7.04
libsmbclient - 3.0.24-2ubuntu1.5
samba - 3.0.24-2ubuntu1.5
Ubuntu 6.10
libsmbclient - 3.0.22-1ubuntu4.5
samba - 3.0.22-1ubuntu4.5
Ubuntu 6.06 LTS
libsmbclient - 3.0.22-1ubuntu3.6
samba - 3.0.22-1ubuntu3.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References