USN-562-1: opal vulnerability

8 January 2008

opal vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • opal

Details

Jose Miguel Esparza discovered that certain SIP headers were not correctly validated. A remote attacker could send a specially crafted packet to an application linked against opal (e.g. Ekiga) causing it to crash, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.04
libopal-2.2.0 - 2.2.3.dfsg-2ubuntu2.1
Ubuntu 6.10
libopal-2.2.0 - 2.2.3.dfsg-0ubuntu2.1
Ubuntu 6.06 LTS
libopal-2.2.0 - 2.2.1-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart your session to effect the necessary changes.

References