USN-564-1: Net-SNMP vulnerability

9 January 2008

net-snmp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • net-snmp

Details

Bill Trost discovered that snmpd did not properly limit GETBULK requests. A remote attacker could specify a large number of max-repetitions and cause a denial of service via resource exhaustion.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
snmpd - 5.3.1-6ubuntu2.1
Ubuntu 7.04
snmpd - 5.2.3-4ubuntu1.1
Ubuntu 6.10
snmpd - 5.2.2-5ubuntu1.1
Ubuntu 6.06 LTS
snmpd - 5.2.1.2-4ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References