USN-566-1: OpenSSH vulnerability

9 January 2008

openssh vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • openssh

Details

Jan Pechanec discovered that ssh would forward trusted X11 cookies when untrusted cookie generation failed. This could lead to unintended privileges being forwarded to a remote host.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
openssh-client - 1:4.6p1-5ubuntu0.1
Ubuntu 7.04
openssh-client - 1:4.3p2-8ubuntu1.1
Ubuntu 6.10
openssh-client - 1:4.3p2-5ubuntu1.1
Ubuntu 6.06 LTS
openssh-client - 1:4.2p1-7ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References