USN-567-1: Dovecot vulnerability

10 January 2008

dovecot vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04

Software Description

  • dovecot

Details

It was discovered that in very rare configurations using LDAP, Dovecot may reuse cached connections for users with the same password. As a result, a user may be able to login as another if the connection is reused. The default Ubuntu configuration of Dovecot was not vulnerable.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
dovecot-imapd - 1:1.0.5-1ubuntu2.1
dovecot-pop3d - 1:1.0.5-1ubuntu2.1
Ubuntu 7.04
dovecot-imapd - 1.0.rc17-1ubuntu2.2
dovecot-pop3d - 1.0.rc17-1ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References