USN-579-1: Qt vulnerability

20 February 2008

qt4-x11 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10

Software Description

  • qt4-x11

Details

It was discovered that QSslSocket did not properly verify SSL certificates. A remote attacker may be able to trick applications using QSslSocket into accepting invalid SSL certificates.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libqt4-core - 4.3.2-0ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart applications linked against Qt to effect the necessary changes.

References