USN-584-1: OpenLDAP vulnerabilities

5 March 2008

openldap2.2, openldap2.3 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • openldap2.3
  • openldap2.2

Details

Jonathan Clarke discovered that the OpenLDAP slapd server did not properly handle modify requests when using the Berkeley DB backend and specifying the NOOP control. An authenticated user with modify permissions could send a crafted modify request and cause a denial of service via application crash. Ubuntu 7.10 is not affected by this issue. (CVE-2007-6698)

Ralf Haferkamp discovered that the OpenLDAP slapd server did not properly handle modrdn requests when using the Berkeley DB backend and specifying the NOOP control. An authenticated user with modrdn permissions could send a crafted modrdn request and possibly cause a denial of service via application crash. (CVE-2007-6698)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
slapd - 2.3.35-1ubuntu0.2
Ubuntu 7.04
slapd - 2.3.30-2ubuntu0.2
Ubuntu 6.10
slapd - 2.2.26-5ubuntu3.3
Ubuntu 6.06 LTS
slapd - 2.2.26-5ubuntu2.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References