USN-589-1: unzip vulnerability

20 March 2008

unzip vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • unzip

Details

Tavis Ormandy discovered that unzip did not correctly clean up pointers. If a user or automated service was tricked into processing a specially crafted ZIP archive, a remote attacker could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
unzip - 5.52-10ubuntu1.1
Ubuntu 7.04
unzip - 5.52-9ubuntu3.1
Ubuntu 6.10
unzip - 5.52-8ubuntu1.1
Ubuntu 6.06 LTS
unzip - 5.52-6ubuntu4.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References