USN-590-1: bzip2 vulnerability

24 March 2008

bzip2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • bzip2

Details

It was discovered that bzip2 did not correctly handle certain malformed archives. If a user or automated system were tricked into processing a specially crafted bzip2 archive, applications linked against libbz2 could be made to crash, possibly leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
libbz2-1.0 - 1.0.4-0ubuntu2.1
Ubuntu 7.04
libbz2-1.0 - 1.0.3-6ubuntu0.1
Ubuntu 6.10
libbz2-1.0 - 1.0.3-3ubuntu0.1
Ubuntu 6.06 LTS
libbz2-1.0 - 1.0.3-0ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References