USN-601-1: Squid vulnerability

14 April 2008

squid vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

  • squid

Details

It was discovered that Squid did not perform proper bounds checking when processing cache update replies. A remote authenticated user may be able to trigger an assertion error and cause a denial of service. This vulnerability is due to an incorrect upstream fix for CVE-2007-6239. (CVE-2008-1612)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
squid - 2.6.14-1ubuntu2.2
Ubuntu 7.04
squid - 2.6.5-4ubuntu2.2
Ubuntu 6.10
squid - 2.6.1-3ubuntu1.7
Ubuntu 6.06 LTS
squid - 2.5.12-4ubuntu2.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References