USN-607-1: Emacs vulnerabilities

6 May 2008

emacs21, emacs22 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.06 LTS

Software Description

  • emacs22
  • emacs21

Details

It was discovered that Emacs did not account for precision when formatting integers. If a user were tricked into opening a specially crafted file, an attacker could cause a denial of service or possibly other unspecified actions. This issue does not affect Ubuntu 8.04. (CVE-2007-6109)

Steve Grubb discovered that the vcdiff script as included in Emacs created temporary files in an insecure way when used with SCCS. Local users could exploit a race condition to create or overwrite files with the privileges of the user invoking the program. (CVE-2008-1694)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
emacs22 - 22.1-0ubuntu10.1
emacs22-bin-common - 22.1-0ubuntu10.1
Ubuntu 7.10
emacs22 - 22.1-0ubuntu5.2
emacs22-bin-common - 22.1-0ubuntu5.2
Ubuntu 7.04
emacs21 - 21.4a+1-2ubuntu1.2
emacs21-bin-common - 21.4a+1-2ubuntu1.2
Ubuntu 6.06 LTS
emacs21 - 21.4a-3ubuntu2.2
emacs21-bin-common - 21.4a-3ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Emacs to effect the necessary changes.

References