USN-630-1: ffmpeg vulnerability

28 July 2008

ffmpeg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS
  • Ubuntu 7.10

Software Description

  • ffmpeg

Details

It was discovered that ffmpeg did not correctly handle STR file demuxing. If a user were tricked into processing a malicious STR file, a remote attacker could execute arbitrary code with user privileges via applications linked against ffmpeg.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
libavformat1d - 3:0.cvs20070307-5ubuntu7.1
Ubuntu 7.10
libavformat1d - 3:0.cvs20070307-5ubuntu4.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References