USN-634-1: OpenLDAP vulnerability

1 August 2008

openldap2.2, openldap2.3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.06 LTS

Software Description

  • openldap2.3
  • openldap2.2

Details

Cameron Hotchkies discovered that OpenLDAP did not correctly handle certain ASN.1 BER data. A remote attacker could send a specially crafted packet and crash slapd, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
slapd - 2.4.9-0ubuntu0.8.04.1
Ubuntu 7.10
slapd - 2.3.35-1ubuntu0.3
Ubuntu 7.04
slapd - 2.3.30-2ubuntu0.3
Ubuntu 6.06 LTS
slapd - 2.2.26-5ubuntu2.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References