USN-636-1: Postfix vulnerability

19 August 2008

postfix vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.06 LTS

Software Description

  • postfix

Details

Sebastian Krahmer discovered that Postfix was not correctly handling mailbox ownership when dealing with Linux’s implementation of hardlinking to symlinks. In certain mail spool configurations, a local attacker could exploit this to append data to arbitrary files as the root user. The default Ubuntu configuration was not vulnerable.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
postfix - 2.5.1-2ubuntu1.1
Ubuntu 7.10
postfix - 2.4.5-3ubuntu1.2
Ubuntu 7.04
postfix - 2.3.8-2ubuntu0.2
Ubuntu 6.06 LTS
postfix - 2.2.10-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References