USN-648-1: nasm vulnerability

30 September 2008

nasm vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS

Software Description

  • nasm

Details

Philipp Thomas discovered that the ppscan function of nasm contained an off-by-one error. If a user or automated system were tricked into assembling a specially crafted ASM file, a remote attacker could execute arbitrary commands with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
nasm - 0.99.06-2ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References