USN-650-1: cpio vulnerability

2 October 2008

cpio vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 7.04
  • Ubuntu 6.06 LTS

Software Description

  • cpio

Details

A buffer overflow was discovered in cpio. If a user were tricked into opening a crafted cpio archive, an attacker could cause a denial of service via application crash, or possibly execute code with the privileges of the user invoking the program. (CVE-2007-4476)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
cpio - 2.8-1ubuntu2.2
Ubuntu 7.04
cpio - 2.6-17ubuntu0.7.04.1
Ubuntu 6.06 LTS
cpio - 2.6-10ubuntu0.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References