USN-665-1: Netpbm vulnerability

6 November 2008

netpbm-free vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software Description

  • netpbm-free

Details

It was discovered that Netpbm could be made to overrun a buffer when loading certain images. If a user were tricked into opening a specially crafted GIF image, remote attackers could cause a denial of service or execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
netpbm - 2:10.0-11ubuntu0.1
Ubuntu 6.06 LTS
netpbm - 2:10.0-10ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References