USN-693-1: LittleCMS vulnerability

17 December 2008

LittleCMS vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10

Software Description

  • lcms

Details

It was discovered that certain gamma operations in lcms were not correctly bounds-checked. If a user or automated system were tricked into processing a malicious image, a remote attacker could crash applications linked against liblcms1, leading to a denial of service, or possibly execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
liblcms1 - 1.16-10ubuntu0.1
Ubuntu 8.04 LTS
liblcms1 - 1.16-7ubuntu1.1
Ubuntu 7.10
liblcms1 - 1.16-5ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References