USN-724-1: Squid vulnerability

25 February 2009

squid vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10

Software Description

  • squid

Details

Joshua Morin, Mikko Varpiola and Jukka Taimisto discovered that Squid did not properly validate the HTTP version when processing requests. A remote attacker could exploit this to cause a denial of service (assertion failure).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
squid - 2.7.STABLE3-1ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References