USN-726-1: curl vulnerability

3 March 2009

curl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software Description

  • curl

Details

It was discovered that curl did not enforce any restrictions when following URL redirects. If a user or automated system were tricked into opening a URL to an untrusted server, an attacker could use redirects to gain access to abitrary files. This update changes curl behavior to prevent following “file” URLs after a redirect.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
libcurl3 - 7.18.2-1ubuntu4.1
libcurl3-gnutls - 7.18.2-1ubuntu4.1
Ubuntu 8.04 LTS
libcurl3 - 7.18.0-1ubuntu2.1
libcurl3-gnutls - 7.18.0-1ubuntu2.1
Ubuntu 7.10
libcurl3 - 7.16.4-2ubuntu1.1
libcurl3-gnutls - 7.16.4-2ubuntu1.1
Ubuntu 6.06 LTS
libcurl3 - 7.15.1-1ubuntu3.1
libcurl3-gnutls - 7.15.1-1ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References