USN-735-1: GStreamer Base Plugins vulnerability

16 March 2009

gst-plugins-base0.10 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10

Software Description

  • gst-plugins-base0.10

Details

It was discovered that the Base64 decoding functions in GStreamer Base Plugins did not properly handle large images in Vorbis file tags. If a user were tricked into opening a specially crafted Vorbis file, an attacker could possibly execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
gstreamer0.10-plugins-base - 0.10.21-3ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References