USN-75-1: cpio vulnerability

4 February 2005

cpio vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 4.10

Software Description

Details

Recently it was discovered that cpio created world-writeable files when used in -o/–create mode with giving an output file (with -O). This allowed any user to modify the created cpio archives. Now cpio respects the current umask setting of the user.

Note: This vulnerability has already been fixed in a very old version of cpio, but the fix was never ported to the current version. Therefore the CAN number was assigned to the year 1999.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 4.10
cpio

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References