USN-750-1: OpenSSL vulnerability

30 March 2009

openssl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software Description

  • openssl

Details

It was discovered that OpenSSL did not properly validate the length of an encoded BMPString or UniversalString when printing ASN.1 strings. If a user or automated system were tricked into processing a crafted certificate, an attacker could cause a denial of service via application crash in applications linked against OpenSSL.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
libssl0.9.8 - 0.9.8g-10.1ubuntu2.2
Ubuntu 8.04 LTS
libssl0.9.8 - 0.9.8g-4ubuntu3.5
Ubuntu 7.10
libssl0.9.8 - 0.9.8e-5ubuntu3.4
Ubuntu 6.06 LTS
libssl0.9.8 - 0.9.8a-7ubuntu0.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to reboot your computer to effect the necessary changes.

References